SODERZhANIE_otcheta


СОДЕРЖАНИЕ
ВВЕДЕНИЕ стр. 3
1 ОБЩАЯ ЧАСТЬ 4
Общие сведения о сети Интернет 4
Виды подключения к Интернет 5
Беспроводные технологии доступа 8
Проводные технологии доступа 9
Службы Интернет. E-MAIL. FTP. TELNET 10
Настройка компьютерной сети 11
Понятие IP-адреса, маска подсети, основной шлюз 15
Общие сведения об архитектуре семейства протоколов TCP/IP 17
Прикладной уровень. Протоколы FTP, TFTP, TELNET, SMTP, POP, HTTP 19
СПЕЦИАЛЬНАЯ ЧАСТЬ 21
Постановка задачи №1 21
2.1.1 Скрины задания №1 21
2.2 Постановка задачи №2 23
2.2.1 Скрины задания №2 23
2.3Постановка задачи №3 25
2.3.1 Скрины задания №3 25
2.4 Постановка задачи №4 30
2.4.1 Скрины задания №4 30
2.5 Постановка задачи №5 32
2.5.1 Скрины задания №5 32
2.6 Постановка задачи №6 34
2.6.1 Скрины задания №6 34
2.7 Постановка задачи №7 36
2.7.1 Скрины задания №7 36
ЗАКЛЮЧЕНИЕ 39
СПИСОК ЛИТЕРАТУРЫ 40

Введение
Packet Tracer — симулятор сети передачи данных, выпускаемый фирмой Cisco Systems. Позволяет делать работоспособные модели сети, настраивать (командами Cisco IOS) маршрутизаторы и коммутаторы, взаимодействовать между несколькими пользователями (через облако). В симуляторе реализованы серии маршрутизаторов Cisco 800, 1800, 1900, 2600, 2800, 2900 и коммутаторов Cisco Catalyst 2950, 2960, 3560, а также межсетевой экран ASA 5505. Беспроводные устройства представлены маршрутизатором Linksys WRT300N, точками доступа и сотовыми вышками. Кроме того есть серверы DHCP, HTTP, TFTP, FTP, DNS, AAA, SYSLOG, NTP и EMAIL, рабочие станции, различные модули к компьютерам и маршрутизаторам, IP-фоны, смартфоны, хабы, а также облако, эмулирующее WAN. Объединять сетевые устройства можно с помощью различных типов кабелей, таких как прямые и обратные патч-корды, оптические и коаксиальные кабели, последовательные кабели и телефонные пары.
Успешно позволяет создавать даже сложные макеты сетей, проверять на работоспособность топологии. Однако, стоит заметить, что реализованная функциональность устройств ограничена и не предоставляет всех возможностей реального оборудования. Cisco Packet Tracer доступен бесплатно для участников Программы Сетевой Академии Cisco.

1.Общая часть
Общие сведения о сети Интернет
Интернет (Internet) – это сеть, объединяющая отдельные локальные, региональные, национальные и глобальные сети, это глобальное сообщество мировых ИВС, которые используют для информационного обмена семейство протоколов TCP/IP.
Дословно термин «Internet» означает «между сетей». Это отражает основную функцию Internet - объединение не только отдельных ЭВМ (хост-машин), но и обеспечение связи между различными сетями в глобальном масштабе. Это объединение даёт возможность обмена информацией между всеми ЭВМ, входящими в сети, подключённые к Internet. При этом не важно, в какой операционной системе работают хост-машины (Windows, UNIX и т.п.).
 Справка. Определение термина Internet было дано 24.10.1995 года Федеральным советом США по компьютерным сетям (FNC - Federal Networking Council): "Internet - это глобальная информационная система, которая логически соединена посредством адресного пространства, основанного на протоколе IP (Internet Protokol) или заменяющих его протоколов, способна поддерживать передачу данных посредством протокола ТСР (Transmission Contrel Protocol) или заменяющих его протоколов, обеспечивает, использует или делает доступными услуги по передаче данных и соответствующую инфраструктуру".

1.2 Виды подключения к Интернет
Сегодня невозможно себе представить человека, которому хотя бы раз не пришлось воспользоваться Интернетом. Всемирная Паутина опутала своими сверхскоростными кабелями буквально все материки и страны. Самый простой способ посидеть в Интернете – это прибегнуть к услугам общественных заведений с зонами Wi-Fi, где вы сможете просмотреть почту, сообщения в социальных сетях или почитать новости, подключив к Сети свой смартфон, планшет или ноутбук через модуль Wi-Fi. Да и с постоянным интернет-подключением дома или в офисе у жителей городов, как правило, не возникает никаких проблем. Всемирную Паутину при желании протянуть можно даже в самые отдаленные местности.
Для выхода в Интернет существует несколько способов его подключения, которые отличаются друг от друга, собственно, самой технологией подключения, тарифами за пользование, а также техническими характеристиками, которые определяют и скорость передачи информации, и стабильность самого подключения, и время отклика, и прочие тонкости. Как видим, качество Интернета зависит не только от аппаратных мощностей используемого компьютерного или мобильного устройства, как некоторые полагают. За качество самого интернет-подключения отвечают поставщики этой услуги – специальные организации, так называемые провайдеры.
1. Спутниковый Интернет
Радиус покрытия этого вида подключения самый широкий из всех возможных, благодаря чему воспользоваться Интернетом можно в любой точке земного шара. Однако спутниковый Интернет так и остался не особо востребованным по нескольким причинам. Во-первых, этот вид подключения обеспечивает односторонний доступ, т.е., передача информации возможна только из Сети к пользователю, обратной передачи нет. Во-вторых, этот вид подключения имеет сравнительно низкую надежность и зависит от метеорологических условий. Если спутник попадет в «теневые зоны», связь резко ухудшается или пропадает вовсе. Есть и другие недостатки - например, очень дорогое оборудование для подключения, высокая стоимость пользования, невысокая скорость отклика. Поэтому такой вид подключения можно выбирать только в том случае, если вы живете далеко от цивилизации и другого способа просто нет.
2. Мобильный Интернет
Само название говорит за себя. Это Интернет, которым вы можете воспользоваться, где бы вы не находились в зоне покрытия провайдера (мобильного оператора). Здесь есть два варианта подключения: через мобильный телефон или через специальный модем. Последний можно подсоединить к смартфону, планшету или ноутбуку через порты USB (miniUSB) в качестве отдельного небольшого устройства. Таким модемом часто производители аппаратно комплектуют некоторые модели компьютерной и мобильной техники.
Практически все современные мобильные телефоны имеют выход в Интернет. Несколько устаревшие модели подключаются по медленной и, в то же время, дорогостоящей технологии GPRS. А для более современных мобильных устройств – смартфонов и планшетов - мобильные операторы предлагают высокоскоростные технологии подключения, которые способны обеспечить доступ к Интернету везде, где есть покрытие этого оператора. Это такие технологии как: CDMA, WiMAX, LTE, UMTS. Если гаджет не оснащен встроенным модемом, способным поддерживать эти технологии, практически все мобильные операторы могут предложить свой брендовый подсоединяемый модем.
Скорость передачи данных у этих технологий может сильно различаться в разных местах нахождения пользователя. Однако сейчас выпускаются специальные усилители интернет-сигнала, которые способны эту скорость в разы увеличить.
3. Телефонное соединение (диалап)
Это на сегодняшний день один из самых распространенных способов подключения к Интернету в России, но далеко не самый лучший. Используется в том случае, если в квартиру проведен стационарный телефон. Подключив компьютер или ноутбук через проводной модем к телефонной линии, вы получаете доступ к Интернету. Телефон в это время, естественно, будет занят, и им нельзя будет воспользоваться до окончания сеанса работы в Сети. И это не единственный недостаток телефонного соединения – так, этот способ интернет-соединения один из самых дорогостоящих, при этом, пожалуй, самый медленный.
4. Wi-Fi
Wi-Fi (Wireless Fidelity) – это один из современных видов беспроводной связи. Практически на всех смартфонах, планшетах и ноутбуках встроен специальный модуль, который позволяет выходить в Интернет, находясь в зоне действия Wi-Fi точек доступа (обычно радиус действия около 100 м). Модуль Wi-Fi также можно приобрести отдельно и подключить к ПК как отдельной встраиваемой платой, так и в виде внешнего устройства, подключаемого по USB.
Пока этот вид подключения у пользователей России не пользуется широким спросом, несмотря на то, что многие, подключив сетевой интернет-кабель к роутеру, могли бы свободно перемещаться по всему дому с ноутбуком, планшетом или смартфоном и пользоваться Интернетом. В России Wi-Fi является скорее дополнительной фишкой для сервисного бизнеса. Пользователи могут (как правило, совершенно бесплатно) иметь доступ к Интернету в различных публичных местах – в аэропортах, на вокзалах, в кафе, гостиницах, на автозаправках и т.д.
Сама по себе технология Wi-Fi достаточно скоростная, но из-за того, что точки доступа обычно бывают перегружены, конечная скорость иногда оставляет желать лучшего.
5. ADSL
ADSL представляет собой особый вид подключения к Интернету по телефонной линии, при этом выход в Интернет никак не мешает работе телефона. Качество такого соединения на порядок выше, чем при обычном телефонном соединении. Оно имеет высокую скорость передачи информации и отличную устойчивость.
6. Прямое подключение
Это наилучший на сегодняшний день способ подключения к Интернету. Компьютер пользователя соединен с провайдером обычным сетевым кабелем. Достоинства этого подключения в его высокой скорости, стабильности, надежности, низкой стоимости. Но доступен этот способ, к сожалению, лишь в больших населенных пунктах – там, где проходят линии кабелей местных провайдеров.
1.3Беспроводные технологии
Беспроводные технологии — подкласс информационных технологий, служат для передачи информации на расстояние между двумя и более точками, не требуя связи их проводами. Для передачи информации могут использоваться радиоволны, а также инфракрасное, оптическое или лазерное излучение.
Существует множество беспроводных технологий, наиболее часто известных по маркетинговым названиям, таким как Wi-Fi, WiMAX, Bluetooth. Каждая технология обладает определёнными характеристиками, которые определяются её областью применения.
Существуют различные подходы к классификации беспроводных технологий.
По дальности действия:
Беспроводные персональные сети (WPAN — Wireless Personal Area Networks). Примеры технологий — Bluetooth.
Беспроводные локальные сети (WLAN — Wireless Local Area Networks). Примеры технологий — Wi-Fi.
Беспроводные сети масштаба города (WMAN — Wireless Metropolitan Area Networks). Примеры технологий — WiMAX.
Беспроводные глобальные сети (WWAN — Wireless Wide Area Network). Примеры технологий — CSD, GPRS, EDGE, EV-DO, HSPA.
Классификация по дальности действия
По топологии:
«Точка-точка».
«Точка-многоточка».
По области применения:
Корпоративные (ведомственные) беспроводные сети — создаваемые компаниями для собственных нужд.
Операторские беспроводные сети — создаваемые операторами связи для возмездного оказания услуг.
Кратким, но ёмким способом классификации может служить одновременное отображение двух наиболее существенных характеристик беспроводных технологий на двух осях: максимальная скорость передачи информации и максимальное расстояние.

1.4 Проводные технологии доступа
Технологии проводного абонентского доступа имеет смысл разбить на пять основных групп по критерию среды передачи и категориям пользователей. На рис. 1 представлена их классификация.
LAN (Local Area Network) – группа технологий, предназначенных для предоставления корпоративным пользователям услуг доступа к ресурсам локальных вычислительных сетей и использующих в качестве среды передачи структурированные кабельные системы категорий 3, 4 и 5, коаксиальный кабель и оптоволоконный кабель.
DSL (Digital Subscriber Line) – группа технологий, предназначенных для предоставления пользователям ТфОП услуг мультимедиа и использующих в качестве среды передачи существующую инфраструктуру ТфОП.
КТВ (кабельное телевидение) – группа технологий, предназначенных для предоставления пользователям сетей КТВ мультимедийных услуг (за счет организации обратного канала) и использующих в качестве среды передачи оптоволоконный и коаксиальный кабели.
OAN (Optical Access Networks) – группа технологий, предназначенных для предоставления пользователям широкополосных услуг, линии доступа к мультимедийным услугам и использующих в качестве среды передачи оптоволоконный кабель.
СКД (сети коллективного доступа) – группа гибридных технологий для организации сетей доступа в многоквартирных домах; в качестве среды передачи используется существующая в домах инфраструктура ТфОП, радиотрансляционных сетей и сетей электропитания.

1.5 Службы Интернет. E-MAIL. FTP. TELNET
Службы (сервисы) – это виды услуг, которые оказываются серверами сети Internet.
    В истории Интернет существовали разные виды сервисов, одни из которых в настоящее время уже не используются, другие постепенно теряют свою популярность, в то время как третьи переживают свой расцвет.
    Перечислим те из сервисов, которые не потеряли своей актуальности на данный момент:
World Wide Web – всемирная паутина – служба поиска и просмотра гипертекстовых документов, включающих в себя графику, звук и видео.
E-mail – электронная почта – служба передачи электронных сообщений.
Usenet, News – телеконференции, группы новостей – разновидность сетевой газеты или доски объявлений.
FTP – служба передачи файлов.
ICQ – служба для общения в реальном времени с помощью клавиатуры.
Telnet – служба удаленного доступа к компьютерам.
Gopher – служба доступа к информации с помощью иерархических каталогов.
    Среди последних служб лидирующее место по объему хранимой информации занимает служба WWW, поскольку данная служба наиболее удобна для работы пользователей и наиболее прогрессивна в техническом плане. На втором месте находится служба FTP, поскольку какие бы интерфейсы и удобства не разрабатывали для пользователя, информация все равно хранится в файлах, доступ к которым и обеспечивает эта служба. Службы Gopher и Telnet в настоящее время можно считать «отмирающими», так как новая информация уже почти не поступает на серверы этих служб и количество таких серверов и их аудитория практически не увеличивается.

1.6 Настройка компьютерной сети
Наличие только сетевых адаптеров, проводов и свитча недостаточно для того, чтобы компьютеры могли общаться друг с другом. Необходим свод правил обмена информацией и таким сводом правил является протокол TCP/IP - популярный сетевой протокол, служащий основой Интернета.
При установке Windows XP обнаруживается сетевой адаптер и создается подключение по локальной сети. Как и подключения других типов, оно показано в папке «Сетевые подключения». Если мы зайдем в свойства Сетевого окружения, выберем Подключение по локальной сети и, соответственно зайдем в Свойства подключения мы доберемся до свойств протокола TCP/IP (рисунок 1).
Рис. 1. Доступ к окну с настройками протокола TCP/IP.
Существует два способа получения IP-адреса компьютера автоматический – когда адрес выделяется компьютеру при его подключении. При таком подходе у вас в сети должен быть компьютер, на котором установлен DHCP-сервер, который будет выделять свободные адреса. Такой подход влечет за собой дополнительные сложности при настройке и администрированию компьютерной сети. Так как компьютерная сеть образовательного учреждения относительно невелика, все компьютеры располагаются относительно недалеко друг от друга, имеет смысл выставить статичные IP-адреса.
Каждый IP-адрес – это набор из четырех чисел, разделенных точкой, каждое число может принимать значения от 0 до 255. Каждый сервер, постоянно подключенный к сети интернет, имеет свой постоянный IP-адрес. Для нужд внутренних, локальных сетей существуют зарезервированные группы адресов, которые не используются во внешней сети интернет. Эти адреса начинаются с чисел 192.168. Также у каждого компьютера есть свой собственный зарезервированный адрес 127.0.0.1 синоним «я сам». По этому адресу компьютер может обратиться к себе самому, чтобы получить доступ к какому-нибудь внутреннему веб-ресурсу.
Компьютер, на котором будут располагаться ваши ресурсы, назовем его server, нужно выставить следующие параметры TCP/IP протокола (рисунок 2).

Рис. 2. Настройка IP-адреса компьютера
IP-адрес:192.168.0.1 Маска подсети: 255.255.255.0 (этим мы говорим, что именование компьютеров в сети будет ограничиваться изменением только последнего числа в IP-адресе). Основной шлюз: 192.168.0.1 (server станет шлюзом через который все остальные компьютеры станут связываться друг с другом)
Для всех остальных компьютеров в сети настройка происходит аналогично, только IP-адрес изменяет свое значение на 192.168.0.2, 192.168.0.3 и т.д.
Насколько удачно произошло соединение можно проверить с помощью внутренней Windows-команды ping. На любом ученическом компьютере зайдите в командную строку (Пуск - Выполнить – команда cmd) и в открывшемся окне в командной строке наберите команду: ping 192.168.0.1 (рисунок 3)

Рис. 3. Тестирование соединения компьютеров с помощью команды ping.
Данная программа отправляет четыре пакета данных по указанному IP-адресу и замеряет время отклика. Тот факт, что удаленный компьютер «откликается», говорит, что связь есть. В принципе, больше ничего делать не нужно, но для того, чтобы обращаться к другому компьютеру не по его адресу, а по осмысленному имени, это имя нужно вначале задать. Имя компьютера и имя рабочей группы задается в свойствах компьютера, вкладка «Имя компьютера» (рисунок 4). Имя группы может быть произвольным.
Рис. 4. Изменение имени компьютера.
Всякий раз, когда какой-нибудь компьютер будет включаться, он будет отправлять запрос ко всем компьютерам в диапазоне адресов 192.168.0 (маска определяет, что изменяется только последнее число) и получать отклик от всех включенных удаленных компьютеров.

1.7 Понятие IP-адреса, маска подсети, основной шлюз
Понятие об IP-адресе, определение его функций. Компьютеры имеют персонифицированные IP-адреса, обеспечивающие их сетевую работу. Это и есть их главное предназначение. Также IP-адрес служит для связи компьютеров в локальной и во Всемирной сетях, фиксирует уникальность конкретного компьютера, обеспечивает осуществление соединения через шлюзовые каналы. IP-адрес - это, с одной стороны, двоичное 32-хразрядное число, используемое для идентификации подсети, в которой «расположена» конкретная машина; с другой – ее уникальный, никогда не повторяющийся номер. С целью более легкого восприятия IP-адреса двоичное 32-хразрядное число трансформируют в 4-е десятичных числа, имеющих значения от 0 до 255.
Из нескольких компьютеров образовывается одна подсеть. Их IP-адреса имеют общие фрагменты, отличаются только последней цифрой. Эта ситуация характерна для домашних сетей, которым присваиваются внутренние адреса.
Чтобы сохранить уникальность, избежать совпадения хостовых IP-адресов, их нельзя назначать произвольно. Существуют специальные организации, которые выдают номера (адреса) компьютеров.Они руководствуются специально разработанными классами. Классы адресов – иерархические понятия.
Классы адресов выполняет роль сетевой адресации, а также адресации сетевых компьютеров; кл. В – подсети; кл. С – сетевых хостов. Есть и другие классы, однако они не принимают участия в определении главных адресов. Известны особые IP-адреса. Они назначаются, например, при тестировании, использовании обратной связи и т. д.  
Маска и ее роль. Маска подсети структурирует IP-адрес. Она определяет, какие цифры в нем есть адресом сети, а какие – адресом хоста, например, сервера какой-либо локальной сети, выполняющего определенные функции с целью обслуживания запросов других пользователей этой же сети. Используя двоичное число, маска маскирует (закрывает) некоторую часть IP-адреса, представляющую собой нумерацию подсети.
Например, в условиях домашней сети, в которой есть какое-то количество компьютерных точек, маска подсети скорее всего имеет такое выражение: 255.255.255.0. Она показывает, что при совпадении первых трех цифр IP-адреса с адресом домашнего компьютера эти адреса имеют прямую связь.
В процессе налаживания связей между компьютерными машинами функции масок состоят в том, чтобы определить, где расположен целевой хост - внутри той подсети, в которой лежит и исходный хост или вне ее. Во втором случае исходный для системы хост отправляет данные на IP-адрес основного шлюза. Маска дает сведения о том, какие именно компьютеры связаны одной сетью и с каким конкретным компьютером. Она также дает информацию, для какого соединения нужен шлюз. Маску можно сравнить с идентификационной матрицей, «накладывающейся» на компьютерный адрес для соединения.
Что такое шлюз? Это путь, открываемый маршрутизатором (модемом, сервером), чтобы какой-либо компьютер мог связаться со Всемирной системой Интернет, найти страницу в удаленном сервере. Без шлюза сетевые связи невозможны.   Пример основного шлюза Обычно рассмотренными понятиями оперируют специалисты, но их значением надо обязательно овладеть тем, кто хотел бы самостоятельно настраивать компьютерную сеть.

1.8 Общие сведения об архитектуре семейства протоколов TCP/IP
Все многообразие сетевых приложений и многомиллионная всемирная компьютерная сеть выросли из четырехкомпьютерной сети ARPANET, созданной по заказу Министерства Обороны США и связавшей вычислительные комплексы в Стэндфордском исследовательском институте, Калифорнийском университете в Санта-Барбаре, Калифорнийском университете в Лос-Анджелесе и университете Юты. Первая передача информации между двумя компьютерами сети ARPANET состоялась в октябре 1969 года, и эту дату принято считать датой рождения нелокальных компьютерных сетей. (Необходимо отметить, что дата является достаточно условной, так как первая связь двух удаленных компьютеров через коммутируемые телефонные линии была осуществлена еще в 1965 году, а реальные возможности для разработки пользователями ARPANET сетевых приложений появились только в 1972 году.) Эта сеть росла и почковалась, закрывались ее отдельные части, появлялись ее гражданские аналоги, они сливались вместе, и в результате «что выросло – то выросло».
При создании ARPANET был разработан протокол сетевого взаимодействия коммуникационных узлов – Network Control Protocol (NCP), осуществлявший связь посредством передачи датаграмм (см. лекцию 14, раздел «Связь с установлением логического соединения и передача данных с помощью сообщений»). Этот протокол был предназначен для конкретного архитектурного построения сети и базировался на предположении, что сеть является статической и настолько надежной, что компьютерам не требуется умения реагировать на возникающие ошибки. По мере роста ARPANET и необходимости подключения к ней сетей, построенных на других архитектурных принципах (пакетные спутниковые сети, наземные пакетные радиосети), от этого предположения пришлось отказаться и искать другие подходы к построению сетевых систем. Результатом исследований в этих областях стало появление семейства протоколов TCP/IP, на базе которого обеспечивалась надежная доставка информации по неоднородной сети. Это семейство протоколов до сих пор занимает ведущее место в качестве сетевой технологии, используемой в операционной системе UNIX. Именно поэтому мы и выбрали его для практической иллюстрации общих сетевых решений.
Семейство протоколов TCP/IP построено по «слоеному» принципу. Хотя оно и имеет многоуровневую структуру, его строение отличается от строения эталонной модели OSI, предложенной стандартом ISO. Это и неудивительно, так как основные черты семейства TCP/IP были заложены до появления эталонной модели и во многом послужили толчком для ее разработки. В семействе протоколов TCP/IP можно выделить четыре уровня:
Уровень сетевого интерфейса.
Уровень Internet.
Транспортный уровень.
Уровень приложений/процессов.

1.9 Прикладной уровень. Протоколы FTP, TFTP, TELNET, SMTP, POP, HTTP
В основе любого взаимодействия лежит протокол — некие правила, определяющие порядок обмена информацией и ее вид. При общении между людьми такой протокол называется этикетом. Он зависит от культурных традиций, характера взаимоотношений собеседников, текущей ситуации. В компьютерных сетях протокол определяется задачей, для выполнения которой он создавался. Чтобы передать информацию от одной системы к другой, например, от вашего подключенного к Интернету компьютера на любой сайт, используется целое многоуровневое семейство протоколов.
На самом верхнем уровне, называемом прикладным, вы набираете адрес (или ищете в журнале, или пользуетесь избранными ссылками) в программе Internet Explorer, Opera, Firefox или другой, жмете клавишу Enter и ждете. Протокол прикладного уровня хватает этот адрес, добавляет к нему служебную информацию, разбивает при необходимости получившиеся данные на кусочки, упаковывает каждый кусочек особым образом и передает протоколу, лежащему уровнем ниже. Такая процедура повторяется несколько раз, в результате чего ваши кусочки превращаются в колебания напряжения в линиях передачи, например, телефонных, или радиосигналы в случае беспроводного Интернета.
Именно в таком виде их получает система, для которой данные предназначены. Она проделывает с ними то же самое, что и ваша, только в обратном порядке. Данные через серию преобразований поднимаются на прикладной уровень, где их можно интерпретировать. Например, сообразить, что вы запросили у веб-сервера файл index. html, находящийся в каталоге www. После чего описанным уже способом отправить вам долгожданную страницу. Если надо, с картинками.
В общем виде так работает любой протокол прикладного уровня семейства TCP/IP, которое в силу исторических причин большинство из нас используют при обращении к сети Интернет. Наиболее часто мы сталкиваемся с протоколами HTTP, FTP, POP3, SMTP, реже — telnet.
HTTP — протокол передачи гипертекста. С его помощью ваша программа веб-навигатор общается с веб-серверами. Общение представляет собой отправку запросов и получение ответов. Ответы содержат запрашиваемые данные — документы, рисунки, исполняемые файлы и другое. Именно этот протокол позволяет вам просматривать веб-страницы.
FTP — протокол передачи файлов. Его мы используем, чтобы отправить или получить файлы с удаленного компьютера. Для этого на одном из компьютеров должна быть установлена, настроена и запущена служба, которая называется FTP-сервером, а второй компьютер с использованием программы, называемой FTP-клиентом, должен подключиться к первому.
POP3 — почтовый протокол. С помощью него мы получаем свою почту с почтовых серверов, например, mail.ru. Как и в предыдущем случае, на сервере запущена соответствующая служба, а у нас на компьютере установлена и настроена программа-клиент — например, MS Outlook.
SMTP — простой протокол передачи почты. Он позволяет нам отправлять почтовые сообщения со своего компьютера на почтовый сервер. Как и FTP и POP3, этот протокол требует, чтобы сервер «был знаком» с нами, то есть, хранил логическое имя и пароль, с помощью которого мы будем к нему обращаться. Только в некоторых случаях можно обратиться к серверу FTP или SMTP анонимно.
telnet — протокол сетевых телекоммуникаций. Один из старейших прикладных протоколов. С его помощью можно запускать различные процессы на удаленном компьютере, при соответствующих разрешениях, — например, отправить на печать 200 страниц текста «хочу печенья!».

2. Специальная часть
Постановка задачи №1
Добавим на рабочую область программы 2 комутатора Switch-PT. По умолчанию они имеют имена – Switch0 и Switch1.
Добавим на рабочее поле четыре компъютера с именами по умолчанию PC0, PC1, PC2, PC3.
Соединим устройства в сеть Ethernet , как показано на рис.1.4.
Сохраним созданую топологию, нажав кнопку Save (в меню File -> Save).
Откроем свойства устройства PC0 нажав на его изображение.Перейдем к вкладке Desktop и симулируем работу run нажав Command Prompt.
Список команд получим, если введем? и нажмем Enter. Для конфигурирования компьютера воспользуемся командой ipconfig из командной строки, например:
ipconfig 192.168.1.2 255.255.255.0
2.1.1 Скрины задачи №1


Постановка задачи №2
Использование команд для настройки роутеров в cisco
Скрины задачи №2

lefttop

Постановка задачи №3
Использование команд для настройки маршрутизаторов и ARP таблиц
Скрины задачи №3

РОУТЕР 1
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 1.1.1.0 255.250.255.0 172.16.10.2
%Inconsistent address and mask
Router(config)#ip route 1.1.1.0 255.255.255.0 172.16.10.2
Router(config)#
РОУТЕР 2
Router#show arpProtocol Address Age (min) Hardware Addr Type Interface
Internet 10.1.1.2 - 0002.4AAE.A7AA ARPA FastEthernet0/0
Router#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 2/3/5 msRouter#show arpProtocol Address Age (min) Hardware Addr Type Interface
Internet 10.1.1.1 0 00E0.B052.73CC ARPA FastEthernet0/0
Internet 10.1.1.2 - 0002.4AAE.A7AA ARPA FastEthernet0/0
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 10.0.0.0/8 is directly connected, FastEthernet0/0
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 10.1.1.2 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#exit
Router(config)#ip route 172.16.10.0 255.255.255.0 10.1.1.1
Router(config)#ping 172.16.10.1
^
% Invalid input detected at '^' marker.

Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#ping 172.16.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/9 msRouter#show arpProtocol Address Age (min) Hardware Addr Type Interface
Internet 10.1.1.1 2 00E0.B052.73CC ARPA FastEthernet0/0
Internet 10.1.1.2 - 0002.4AAE.A7AA ARPA FastEthernet0/0
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
172.16.0.0/24 is subnetted, 1 subnets
S 172.16.10.0 [1/0] via 10.1.1.1
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#no ip route 172.16.10.0 255.255.255.0 10.1.1.1
Router(config)#ip route 0.0.0.0.0.0.0.0 10.1.1.1
^
% Invalid input detected at '^' marker.

Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1
Router(config)#sh ip route
^
% Invalid input detected at '^' marker.

Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 10.1.1.1 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 10.1.1.1
РОУТЕР 3
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, Serial2/0
Router#ip route 10.1.1.0 255.255.255.0 172.16.10.1
^
% Invalid input detected at '^' marker.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 10.1.1.0 255.255.255.0 172.16.10.1
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
S 10.1.1.0 [1/0] via 172.16.10.1
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, Serial2/0
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#no ip route 10.1.1.0 255.255.255.0 172.16.10.1
Router(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.1
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 172.16.10.1 to network 0.0.0.0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, Serial2/0
S* 0.0.0.0/0 [1/0] via 172.16.10.1
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int loopback 0 1.1.1.1 255.255.255.0
^
% Invalid input detected at '^' marker.

Router(config)#int loopback 0 1.1.1.1 255.255.255.0
^
% Invalid input detected at '^' marker.

Router(config)#int loopback 0 1.1.1.1 255.255.255.0
^
% Invalid input detected at '^' marker.

Router(config)#interface loopback 0 1.1.1.1 255.255.255.0
^
% Invalid input detected at '^' marker.

Router(config)#interface loopback 0
Router(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
Router(config-if)#interface loopback 0 1.1.1.1 255.255.255.0
^
% Invalid input detected at '^' marker.

Router(config-if)#ip route 1.1.1.0 255.250.255.0 172.16.10.2
Постановка задачи №4
Использование команд для настройки роутеров в cisco
2.4.1 Скрины задачи №4

Router2#sh ip route
Router4#sh ip route
Router1(config)#router rip Router1(config-router)#network 172.16.10.0
Router1(config-router)#network 10.1.1.0
Router1(config)#router rip
Router1(config)# router rip
Router1(config-router)# network 172.16.10.0 Router1(config-router)# network 10.1.1.0
Router2(config)# router rip
Router2 (config-router)# network 10.1.1.0
Router4(config)# router rip
Router4 (config-router)# network 172.16.10.0
Router2# sh ip route
Router2# ping 172.16.10.2
Router4# sh ip route
Router4#ping 10.1.1.1
Router1# debug ip rip
Router1# no debug ip rip
Router1(config)# router eigrp 100
Router1(config-router)# network 172.16.10.0 Router1(config-router)# network 10.1.1.0
Router2(config)# router eigrp 100
Router2 (config-router)# network 10.1.1.0
Router4(config)# router eigrp 100
Router4 (config-router)# network 172.16.10.0
Router2# sh ip route
Router2#ping 172.16.10.1
Router2# ping 172.16.10.2
Router2# ping 172.16.10.2
Router4#ping 10.1.1.1
Router4# ping 10.1.1.2.
Router4# ping 10.1.1.2.
Router1(config)#router ospf 100
Router1(config-router)# network 172.16.10.0 0.0.0.255 area 0
Router1(config-router)# network 10.1.1.0 0.0.0.255 area 0
Router2(config)#router ospf 100 Router2(config-router)# network 10.1.1.0 0.0.0.255 area 0
Router4(config)# router ospf 100 Router4(config-router)# network 172.16.10.0 0.0.0.255 area 0
Router2# sh ip route
Router2# ping 172.16.10.1
Router2# ping 172.16.10.2
Router4# sh ip route
Router4# ping 10.1.1.2.
Постановка задачи №5
Использование команд для настройки роутеров в cisco
2.5.1 Скрины задачи №5

61595222885Router1#show arp 10.1.1.2
6731036195153035-2811780
105410237490 Router2#ping 10.1.1.1
109855330200

105410198120Router2# show ip route
Router2(config)#ip route 172.16.10.0 255.255.255.0 10.1.1.1
153035248920 Router2#ping 172.16.10.1
153035-6892925
143510262890Router2#ping 172.16.10.2
305435-6740525
143510251460Router4(config)#ip route 10.1.1.0 255.255.255.0 172.16.10.1

Постановка задачи №6
Использование команд для настройки роутеров в cisco
2.6.1 Скрины задачи №6

Router(config)#router rip
Router(config-router)#network 1.0.0.0
Router1(conf)#access-list 100 permit ip 1.1.1.0 0.0.0.127 1.1.3.0 0.0.0.255 log Router1(conf)#access-list 100 permit ip 1.1.2.0 0.0.0.255 any log
Router1#show access-list
Router1(conf)#interface Serial2/0
Router1(conf-if)#ip access-group 100 in
PC#Ping 1.1.3.2

Router2(conf)# access-list 101 deny ip 1.1.1.130 0.0.0.0 1.1.1.3 0.0.0.0 log Router2(conf)# access-list 101 permit ip any anyRouter2#show access-list
5092705842000
Router2(conf)#interface FastEthernet0/0 Router2(conf-if)#ip access-group 101 in
PC5 PC2# Ping 1.1.1.3

Router1(conf)#interface Serial2/0
Router1(conf-if)#no ip access-group 100 in
Router2(conf)#interface FastEthernet0/0
Router2(conf-if)#no ip access-group 101 in
Router2(conf)#access-list 102 deny ip 1.1.1.128 0.0.0.127 1.1.3.2 0.0.0.0 log Router2(conf)#access-list 102 permit ip any any Проверим создание
Router2#show access-list
5092705842000
Router2(conf)#interface Serial2/0
Router2(conf-if)#ip access-group 102 out

Постановка задачи №7
Загрузить в симулятор топологию, и сделать связь между роутерами.
Скрины задачи №7

LG(config)#router ospf 1
LG(config-router)#network 1.1.1.0 0.0.0.255 area 10
LG(config-router)#network 10.1.1.0 0.0.0.255 area 10
LG(config-router)#network 10.1.2.0 0.0.0.255 area 10
G(config)# router ospf 1
G(config-router)#network 1.1.1.0 0.0.0.255 area 10
G(config-router)#network 1.1.2.0 0.0.0.255 area 10
G(config-router)#network 1.1.3.0 0.0.0.255 area 10
L1(config)# router ospf 1
L1(config-router)#network 10.1.1.0 0.0.0.255 area 10
L2(config)# router ospf 1
L2(config-router)# network 10.1.2.0 0.0.0.255 area 10
G1(config)#router ospf 1
G1(config-router)#network 1.1.2.0 0.0.0.255 area 10
G2(config)#router ospf 1
G2(config-router)#network 1.1.3.0 0.0.0.255 area 10
G1(config)#line vty 0 4
G1(config-line)#login
G1(config-line)#password G1
G2(config)# line vty 0 4
G2(config-line)#login
G2(config-line)#password G2
LG(config)#interface s2/0
LG(config-if)#ip nat outside
LG(config-if)#interface fa0/0
LG(config-if)#ip nat inside
LG(config-if)#interface fa1/0
LG(config-if)#ip nat inside
LG(config)#access-list 2 permit 10.1.0.0 0.0.255.255
LG(config)#ip nat inside source list 2 interface s2/0 overload
L1# telnet 1.1.2.2
Password:G1G1> show users
5092705842000
L1# telnet 1.1.3.2
Password:G2G2> show users
5092705842000
L2# telnet 1.1.2.2
Password:G1G1> sh us

L2# telnet 1.1.2.2
Password:G2G2> sh us
5092705842000


Заключение
За данную практику я научился работать с программой Cisco Packet Tracker. А также научился определять сети. Устанавливать сети между компьютерами, Hub’ами, Switch’ами, Роутерами и серверами. Устанавливать пинг и отправлять запросы с одного места в другое. Эта была самая не простая практика так как первый раз работал с сетями.

Список литературы
www.wikipedia.com
https://shkolazhizni.ruhttp://futurewings.ruwww.knowpc.ruwww.titorov.ru

Приложенные файлы

  • docx 18415166
    Размер файла: 918 kB Загрузок: 0

Добавить комментарий